Add bones not working (16.0.8)

Rigging, animation, import/export of characters, props and cameras comprehensive tool set for After Effects.
Forum rules
Please read these rules and advices before posting.
  • Before you ask any question about a tool, to avoid duplicates, please:
    1. Search for a solution in the available guides and documents.
    2. Some video tutorials are available.
    3. Maybe you can find an answer in the frequently asked questions (FAQ).
    4. You can make a search to see if your question has already been asked.
    • Thank you for giving a detailed and precise title to your topics, to help searching in the future.
    • We're very few people to manage this forum, please be patient if we're a bit long to answer.
    • Don't hesitate to answer to other people's questions! The goal of this forum is not only to have the Rainbox team answer users' questions, but to have everyone sharing and helping each other.
    • Finally, please always be polite, and keep in mind that all we want is sharing techniques and knowledge, helping each other.
Post Reply
Labelkills
Posts: 3
Joined: Tue Oct 23, 2018 5:54 pm

Add bones not working (16.0.8)

Post by Labelkills » Tue Oct 23, 2018 6:02 pm

If I use the puppet tool and add pins to a .png layer then select those pins (on the animation panel) and click 'Add bones' in Duik, the preview switches to the 'MAGIC IS HAPPENING' and just sticks there... forever. I have to command + z then close the Duik panel twice (it's frozen and reports an error the second time opening it) to get back to a workable space. The error for the Duik panel after I try to re-open it is "Unable to execute script at line 7696. Expected: ) - undefined is not an object".

This happens if I just import any png or create a shape layer, add puppet pins, select those pins under timeline, then click 'Add bones'. Any help how to move forward? I'm using AE CC 2017 on Windows 10.

Thanks!

User avatar
Duduf
Posts: 416
Joined: Mon Jun 20, 2016 2:59 pm

Re: Add bones not working (16.0.8)

Post by Duduf » Wed Oct 24, 2018 12:56 pm

I've just had another report about this issue, I'm looking into it and it should be fixed soon!

User avatar
Duduf
Posts: 416
Joined: Mon Jun 20, 2016 2:59 pm

Re: Add bones not working (16.0.8)

Post by Duduf » Wed Oct 24, 2018 1:06 pm

I can't reproduce the issue here,
Can you:

- Activate javascript debugging in the preferences of After Effects
- Activate the "dev and debug" mode in the settings of Duik, and then restart Duik

Then, when using the "add bones" tool, an error messsage should be shown, or Ae may even launch the debugger, highlighting a specific line in the script. If it does, can you post a screenshot of the whole window/error ? Thanks!

Labelkills
Posts: 3
Joined: Tue Oct 23, 2018 5:54 pm

Re: Add bones not working (16.0.8)

Post by Labelkills » Wed Oct 24, 2018 5:14 pm

Turned both of these on, but didn't get any message until I restart Duik (cause it freezes). Still just hangs on "MAGIC IS HAPPENING" until I restart Duik and get the same error message as previously written. Happens both on my Macbook and PC.

User avatar
Duduf
Posts: 416
Joined: Mon Jun 20, 2016 2:59 pm

Re: Add bones not working (16.0.8)

Post by Duduf » Wed Oct 24, 2018 7:54 pm

I think I've found what's causing the issue. The tomorrow update should fix this, but let me know if you still have issues after!

Labelkills
Posts: 3
Joined: Tue Oct 23, 2018 5:54 pm

Re: Add bones not working (16.0.8)

Post by Labelkills » Fri Oct 26, 2018 9:48 pm

IT WORKED!!! thank you, thank you! incoming donation

Post Reply