Page 1 of 1

Anchor points is moving when i create bones

Posted: Sun Feb 10, 2019 12:40 pm
by 0absolut
Hello guys,
First of all, sorry for my english

I have an issue when i creating bones with puppet pins. For example, when i create an arm, in my basic position at shoulder i have anchor point in a place but after i rotate the arm, my anchor point is moving a little bit.

I put some pictures with arm in basic position and after i rotate the arm.
https://flic.kr/s/aHsmABdmGj
Photo with horizontal hands is in basic position
Photo with vertical hands is after rotation (anchor point had another position in particular at the real left hand)

I mention that how i create this: one arm is one pice, i put 3 puppet pins, than i create bones, i create a controller at palm position after that i select all this four "pins" and i create IK(2 layer ik & goal)

How can i fix anchor point position and why is happened this?
Thank you and i hope you understand the problem I have.

Re: Anchor points is moving when i create bones

Posted: Mon Feb 11, 2019 10:29 am
by Duduf
I think this is an issue with the puppet tool of After Effects, not bones.

BTW, what is this version of Duik?

Re: Anchor points is moving when i create bones

Posted: Mon Feb 11, 2019 3:06 pm
by 0absolut
Duik version 15.52

Re: Anchor points is moving when i create bones

Posted: Mon Feb 11, 2019 3:22 pm
by Duduf
I think it's time to update ;)

Display the mesh of the puppet tool and see if you have enough triangles, this is usually the cause of this kind of issues.

Re: Anchor points is moving when i create bones

Posted: Mon Feb 11, 2019 7:04 pm
by 0absolut
I've updated it - same problem

At puppet tool: mesh is check, expansion: 0, triangles: 400
What's the right settings or how it's influences rigging this settings?