Puppet Tool and Auto Rig strange bends

Rigging, animation, import/export of characters, props and cameras comprehensive tool set for After Effects.
Forum rules
Please read these rules and advices before posting.
  • Before you ask any question about a tool, to avoid duplicates, please:
    1. Search for a solution in the available official user guide.
    2. Some video tutorials are available.
    3. Maybe you can find an answer in the frequently asked questions (FAQ).
    4. You can make a search to see if your question has already been asked.
    • Thank you for giving a detailed and precise title to your topics, to help searching in the future.
    • We're very few people to manage this forum, please be patient if we're a bit long to answer.
    • Don't hesitate to answer to other people's questions! The goal of this forum is not only to have the Rainbox team answer users' questions, but to have everyone sharing and helping each other.
    • Finally, please always be polite, and keep in mind that all we want is sharing techniques and knowledge, helping each other.
Post Reply
username1
Posts: 2
Joined: Mon Apr 08, 2019 2:07 pm

Puppet Tool and Auto Rig strange bends

Post by username1 » Mon Apr 08, 2019 2:30 pm

Hey, my leg is on one layer, so it's not split into different parts. Therefore I used the Puppet Tool in After Effects and added 3 pins. Then I selected the three pins and clicked "Add Bones" (Use Duik v16.0.11). I added a controller and then pressed Auto-Rig. When I wanted to move the controller, my knees started to bend strangely.


Auto Rig.png
Auto Rig.png (25.73 KiB) Viewed 966 times
Strange Bend.png
Strange Bend.png (17.27 KiB) Viewed 966 times
In the older version of Duik (v11) this always worked. I tried different puppet pin types, as well as different auto rig types. If I only added 2 bones without rig, the knee bent without problems.
Only Bones.png
Only Bones.png (17.58 KiB) Viewed 966 times

I'm not sure if this just doesn't work anymore or if I'm missing something.

Thanks!

User avatar
Duduf
Posts: 618
Joined: Mon Jun 20, 2016 2:59 pm

Re: Puppet Tool and Auto Rig strange bends

Post by Duduf » Mon Apr 08, 2019 4:04 pm

I think this is just because you're using the new puppet engine in one of the latest versions of After Effects. Just switch to the legacy engine and it should bend as before.

username1
Posts: 2
Joined: Mon Apr 08, 2019 2:07 pm

Re: Puppet Tool and Auto Rig strange bends

Post by username1 » Tue Apr 09, 2019 5:59 am

Thanks for your help!
And where can I find the legacy engine?

Post Reply