Bassel - Can't seem to figure out Parent Across Comps

Rigging, animation, import/export of characters, props and cameras comprehensive tool set for After Effects.
Forum rules
Please read these rules and advices before posting.
  • Before you ask any question about a tool, to avoid duplicates, please:
    1. Search for a solution in the available official user guide.
    2. Some video tutorials are available.
    3. Maybe you can find an answer in the frequently asked questions (FAQ).
    4. You can make a search to see if your question has already been asked.
    • Thank you for giving a detailed and precise title to your topics, to help searching in the future.
    • We're very few people to manage this forum, please be patient if we're a bit long to answer.
    • Don't hesitate to answer to other people's questions! The goal of this forum is not only to have the Rainbox team answer users' questions, but to have everyone sharing and helping each other.
    • Finally, please always be polite, and keep in mind that all we want is sharing techniques and knowledge, helping each other.
Post Reply
dreyeshhh
Posts: 3
Joined: Wed Apr 17, 2019 2:31 am

Bassel - Can't seem to figure out Parent Across Comps

Post by dreyeshhh » Wed Apr 17, 2019 2:42 am

I've read this https://rainbox-dev.github.io/DuAEF_Dui ... positions/ and I feel like I'm doing something wrong.

I'm trying to parent a camera in a precomp to the comp the precomp belongs to. Unfortunately, I'm not getting a locator null in the child's precomp. Only the parent's precomp creates a locator null.

I'm on Mojave Mac OS, AE 2019, Bassel 16.0.11

User avatar
Duduf
Posts: 618
Joined: Mon Jun 20, 2016 2:59 pm

Re: Bassel - Can't seem to figure out Parent Across Comps

Post by Duduf » Wed Apr 17, 2019 12:11 pm

This seems to be a bug.

I don't think I have tested it with camera, maybe not even with 3D Layers. I'm adding this in my todo list and fix this for the next version

User avatar
Duduf
Posts: 618
Joined: Mon Jun 20, 2016 2:59 pm

Re: Bassel - Can't seem to figure out Parent Across Comps

Post by Duduf » Wed Apr 17, 2019 12:11 pm

In the meantime, you may try to parent the camera to a null object, and use the tool on the null object instead of the camera itself!

dreyeshhh
Posts: 3
Joined: Wed Apr 17, 2019 2:31 am

Re: Bassel - Can't seem to figure out Parent Across Comps

Post by dreyeshhh » Wed Apr 17, 2019 2:54 pm

Ah! Good to know I wasn't just misunderstanding the instructions. Parenting the camera to a null object works! Thanks so much!

dreyeshhh
Posts: 3
Joined: Wed Apr 17, 2019 2:31 am

Re: Bassel - Can't seem to figure out Parent Across Comps

Post by dreyeshhh » Wed Apr 17, 2019 3:01 pm

Also, just as an fyi, when parenting layers across comps, I had to manually turn on the 3D toggle for both locators before they could move in 3D

User avatar
Duduf
Posts: 618
Joined: Mon Jun 20, 2016 2:59 pm

Re: Bassel - Can't seem to figure out Parent Across Comps

Post by Duduf » Thu Apr 18, 2019 12:04 pm

ok, trhanks for the feedback, I'll fix this!

Post Reply