Page 1 of 1

DUIK Connector not working for TimeRemap comp

Posted: Thu May 16, 2019 11:58 pm
by xieli_1994
Hi,

I tried to use DUIK controller to control my character eye position. The left eye and the right eye are located in separate comps with Time Remap. In each eye comp I have pupil layer and trying to control them out of the composition. Here's the problem, the connector works fine without keyframe. It stopped working once I add a keyframe(nothing happened if I move the connector). I tried to re-connect several times but the problem still happening. Here I uploaded a Youtube video to demonstrate my problem.

https://youtu.be/CJDhN3YqGqU

Re: DUIK Connector not working for TimeRemap comp

Posted: Fri May 17, 2019 12:10 am
by xieli_1994
xieli_1994 wrote:
Thu May 16, 2019 11:58 pm
Hi,

I tried to use DUIK controller to control my character eye position. The left eye and the right eye are located in separate comps with Time Remap. In each eye comp I have pupil layer and trying to control them out of the composition. Here's the problem, the controller works fine without keyframe. It stopped working once I add a keyframe(nothing happened if I move the connector). I tried to re-connect several times but the problem still happening. Here I uploaded a Youtube video to demonstrate my problem.

https://youtu.be/CJDhN3YqGqU
Wondering if it's my mis-operation?

Re: DUIK Connector not working for TimeRemap comp

Posted: Fri May 17, 2019 9:58 am
by Duduf
If you're freezing the layer with the time remap, you won't see any animation in it

Re: DUIK Connector not working for TimeRemap comp

Posted: Fri May 17, 2019 11:53 am
by xieli_1994
Hi,

Thank you for your reply! I double checked my AE file and I’m sure that I didn’t lock my eye comp (with time remap on it) or anything inside the the eye comp.

Re: DUIK Connector not working for TimeRemap comp

Posted: Fri May 17, 2019 2:39 pm
by Duduf
I mean, time remap on your comp freezes its time on the first frame.
Why would you need it anyway?