An error has occured at line 8897 while creating structures

Rigging, animation, import/export of characters, props and cameras comprehensive tool set for After Effects.
Forum rules
Please read these rules and advices before posting.
  • Before you ask any question about a tool, to avoid duplicates, please:
    1. Search for a solution in the available official user guide.
    2. Some video tutorials are available.
    3. Maybe you can find an answer in the frequently asked questions (FAQ).
    4. You can make a search to see if your question has already been asked.
    • Thank you for giving a detailed and precise title to your topics, to help searching in the future.
    • We're very few people to manage this forum, please be patient if we're a bit long to answer.
    • Don't hesitate to answer to other people's questions! The goal of this forum is not only to have the Rainbox team answer users' questions, but to have everyone sharing and helping each other.
    • Finally, please always be polite, and keep in mind that all we want is sharing techniques and knowledge, helping each other.
Post Reply
mickeymilano
Posts: 4
Joined: Wed Jun 19, 2019 10:51 am

An error has occured at line 8897 while creating structures

Post by mickeymilano » Thu Jun 20, 2019 10:44 am

Need help as really need to create an animation by end of week....

For some reasons this error(An error has occured at line 8897 while creating structures) sudden started
to appear (Dev mode) when trying to create structures. I click the button but nothing happens.

I have re installed Duik, re installed AE, got rid of all other plugins and scripts but still it won't work.
Latest version of AE and Mojave 10.14.5 (18F132). Weird thing is that on another Mac same set up it
works fine? Any ideas please? (Duik amazing bit of software as well! Just bought the printed manual.)


Thanks
Mickey

:(

User avatar
Duduf
Posts: 617
Joined: Mon Jun 20, 2016 2:59 pm

Re: An error has occured at line 8897 while creating structures

Post by Duduf » Fri Jun 21, 2019 7:27 am

Hi Mickey,
Have you tried to disable the dev mode? This way the errors should be ignored.

Also, just tell me what version of Duik you're using, I'll have a look at this error and see what's going on!

User avatar
Duduf
Posts: 617
Joined: Mon Jun 20, 2016 2:59 pm

Re: An error has occured at line 8897 while creating structures

Post by Duduf » Fri Jun 21, 2019 7:30 am

hum... 8897 has nothing to do with the Structures, that's weird, it concerns the UI only...

Can you send a screenshot of the complete error shown? thanks!

mickeymilano
Posts: 4
Joined: Wed Jun 19, 2019 10:51 am

Re: An error has occured at line 8897 while creating structures

Post by mickeymilano » Fri Jun 21, 2019 8:22 am

Hi there,

When developer mode in off the structures button just highlight but doesn't do anything so it doesn't show any of the structures panel options.
Very weird as it just happened after I tried to create a humanoid a second time then stop working after I did an undo to redo the humanoid rig.

Here's the screen grabs (on the latest version of Duik 16.0.11) one with dev mode off and other with dev mode on.
I have tried reinstalling AE plus taken out all other scripts and plugins but still nothing?

Cheers
Mickey
Screenshot 2019-06-21 at 09.20.02.png
Screenshot 2019-06-21 at 09.20.02.png (319.5 KiB) Viewed 685 times
Screenshot 2019-06-21 at 09.19.21.png
Screenshot 2019-06-21 at 09.19.21.png (296.34 KiB) Viewed 685 times

User avatar
Duduf
Posts: 617
Joined: Mon Jun 20, 2016 2:59 pm

Re: An error has occured at line 8897 while creating structures

Post by Duduf » Fri Jun 21, 2019 8:43 am

Haha the error does not help a lot :roll:

This line concerns the text colors in the UI of Duik.
It looks like it's a bug in Ae there. Do the texts of the buttons correctly change their colors to red when you go over them with the mouse, then get back to the original grey?

mickeymilano
Posts: 4
Joined: Wed Jun 19, 2019 10:51 am

Re: An error has occured at line 8897 while creating structures

Post by mickeymilano » Fri Jun 21, 2019 10:01 am

Arhh a bug in after effects now there a surprise! Ha ha

The button does change colour but stays red until you click it again then goes back to grey.

mickeymilano
Posts: 4
Joined: Wed Jun 19, 2019 10:51 am

Re: An error has occured at line 8897 while creating structures

Post by mickeymilano » Fri Jun 21, 2019 10:32 am

By complete accident I have managed to fix it. I found some Duik files being stored in my documents folder on my Mac, see attached screen grab.

I deleted these and then restarted AE and bingo all works fine now!

I'm guessing when I kept reinstalling Duik from scratch these files were not being replaced???

Anyway problem solved and hopefully if anyone else has this issue it'll work for them.

Keep up the good work! Hopefully getting my printed manual today (as missed Doh! delivery twice)


Cheers

Mickey

Screenshot 2019-06-21 at 11.26.54.png
Screenshot 2019-06-21 at 11.26.54.png (37.8 KiB) Viewed 681 times

User avatar
Duduf
Posts: 617
Joined: Mon Jun 20, 2016 2:59 pm

Re: An error has occured at line 8897 while creating structures

Post by Duduf » Sun Jun 23, 2019 7:23 am

Oh! Thanks for this feedback, I may get what's wrong.

I'll add a way to reset preferences in case Duik has issues like this, which will replace these files by the defaults. I think they got corrupted (but I don't know why...)

I hope you'll like the manual :)

Post Reply