Connector head/face rig issues

Rigging, animation, import/export of characters, props and cameras comprehensive tool set for After Effects.
Forum rules
Please read these rules and advices before posting.
  • Before you ask any question about a tool, to avoid duplicates, please:
    1. Search for a solution in the available guides and documents.
    2. [url=http://rainboxprod.coop/en/help/#tutorials]Some video tutorials[/url] are available.
    3. Maybe you can find an answer in the [url=https://rainbox-dev.github.io/DuAEF_Duik/Guides/Duik/duik-faq/]frequently asked questions[/url] (FAQ).
    4. You can [url=http://forum.rainboxprod.coop/search.php]make a search[/url] to see if your question has already been asked.
    • Thank you for giving a detailed and precise title to your topics, to help searching in the future.
    • We're very few people to manage this forum, please be patient if we're a bit long to answer.
    • Don't hesitate to answer to other people's questions! The goal of this forum is not only to have the Rainbox team answer users' questions, but to have everyone sharing and helping each other.
    • Finally, please always be polite, and keep in mind that all we want is sharing techniques and knowledge, helping each other.
Post Reply
Ikvisser
Posts: 3
Joined: Wed Feb 06, 2019 9:47 am

Connector head/face rig issues

Post by Ikvisser » Wed Feb 06, 2019 10:07 am

Hi guys,

Thanks so much for the great Duik Bassel: so many wonderful features to discover!

I'm working on a head/face rig for one of my characters. I've looked into the different ways of using the connectors for controlling the head/face. For example I saw this Spanish tutorial (RIGGING de una CARA con DUIK BASSEL (16 ) - TUTORIAL) where multiple properties are connected to a 2d Slider. However when I try to repeat the actions I get an error. I came across another forum topic regarding this issue: https://forum.rainboxprod.coop/viewtopic.php?f=11&t=563
It explains to use different nulls for multiple properties.
However when I try to set only one of my layers with two keyframes (min and max position) to a connector slider or controller (connect to properties or select master property) I get an error.
ExtendScript Toolkit says there's an error on line 3049:
"Can not call setValue() on a property with keyframes. Use setValueAtTime() or setValueAtKey() instead."
Also I have to Purge all memory and disk cache and restart the Duik script twice (error 6473) before I can continue again.

Do you have any ideas on what I'm doing wrong?
Any help would be much appreciated!

I'm using Ae version 14.2.1.34 and Duik Bassel version 16.0.5

Iris

User avatar
Duduf
Posts: 583
Joined: Mon Jun 20, 2016 2:59 pm

Re: Connector head/face rig issues

Post by Duduf » Wed Feb 06, 2019 10:31 am

Hi Iris,

Can you download and install the latest version of Duik?
I think this issue has been fixed.

Let me know if it works!

Ikvisser
Posts: 3
Joined: Wed Feb 06, 2019 9:47 am

Re: Connector head/face rig issues

Post by Ikvisser » Thu Feb 07, 2019 8:37 am

Hi Duduf,

Thanks for the quick reply!
I've downloaded the latest version and unzipped the folder in ScriptUI panels.
However I can't open Duik from Window. I have to go to Scripts.
Maybe it's still referring to an older version, because it says 16.0.5.

Am I missing a step?

Thanks again!

Iris

Ikvisser
Posts: 3
Joined: Wed Feb 06, 2019 9:47 am

Re: Connector head/face rig issues

Post by Ikvisser » Thu Feb 07, 2019 8:45 am

I fixed it: I replaced the older Duik Bassel.jsx version in the Scripts folder and for extra measure I pasted another Duik Bassel.jsx in the ScriptsUI panels next to the complete folder. Now it works :) I'm sorry for the trouble!

I will try the Spanish tutorial again!

Thanks!

Post Reply