Anchor points is moving when i create bones

Rigging, animation, import/export of characters, props and cameras comprehensive tool set for After Effects.
Forum rules
Please read these rules and advices before posting.
  • Before you ask any question about a tool, to avoid duplicates, please:
    1. Search for a solution in the available official user guide.
    2. Some video tutorials are available.
    3. Maybe you can find an answer in the frequently asked questions (FAQ).
    4. You can make a search to see if your question has already been asked.
    • Thank you for giving a detailed and precise title to your topics, to help searching in the future.
    • We're very few people to manage this forum, please be patient if we're a bit long to answer.
    • Don't hesitate to answer to other people's questions! The goal of this forum is not only to have the Rainbox team answer users' questions, but to have everyone sharing and helping each other.
    • Finally, please always be polite, and keep in mind that all we want is sharing techniques and knowledge, helping each other.
Post Reply
0absolut
Posts: 3
Joined: Sun Feb 10, 2019 11:49 am

Anchor points is moving when i create bones

Post by 0absolut » Sun Feb 10, 2019 12:40 pm

Hello guys,
First of all, sorry for my english

I have an issue when i creating bones with puppet pins. For example, when i create an arm, in my basic position at shoulder i have anchor point in a place but after i rotate the arm, my anchor point is moving a little bit.

I put some pictures with arm in basic position and after i rotate the arm.
https://flic.kr/s/aHsmABdmGj
Photo with horizontal hands is in basic position
Photo with vertical hands is after rotation (anchor point had another position in particular at the real left hand)

I mention that how i create this: one arm is one pice, i put 3 puppet pins, than i create bones, i create a controller at palm position after that i select all this four "pins" and i create IK(2 layer ik & goal)

How can i fix anchor point position and why is happened this?
Thank you and i hope you understand the problem I have.

User avatar
Duduf
Posts: 585
Joined: Mon Jun 20, 2016 2:59 pm

Re: Anchor points is moving when i create bones

Post by Duduf » Mon Feb 11, 2019 10:29 am

I think this is an issue with the puppet tool of After Effects, not bones.

BTW, what is this version of Duik?

0absolut
Posts: 3
Joined: Sun Feb 10, 2019 11:49 am

Re: Anchor points is moving when i create bones

Post by 0absolut » Mon Feb 11, 2019 3:06 pm

Duik version 15.52

User avatar
Duduf
Posts: 585
Joined: Mon Jun 20, 2016 2:59 pm

Re: Anchor points is moving when i create bones

Post by Duduf » Mon Feb 11, 2019 3:22 pm

I think it's time to update ;)

Display the mesh of the puppet tool and see if you have enough triangles, this is usually the cause of this kind of issues.

0absolut
Posts: 3
Joined: Sun Feb 10, 2019 11:49 am

Re: Anchor points is moving when i create bones

Post by 0absolut » Mon Feb 11, 2019 7:04 pm

I've updated it - same problem

At puppet tool: mesh is check, expansion: 0, triangles: 400
What's the right settings or how it's influences rigging this settings?

Post Reply